Eclipse 4.2: Tips on API best practices for a 3.x plugin running on both platforms

Session Type: 
Standard [35 minutes]
Speakers

Eclipse 4.2 supports the 3.x workbench API through use of the compatibility layer.  But some 3.x APIs are more architecturally compatible with Eclipse 4 than others.  This talk will touch on 3.x API patterns that are similar to the Eclipse 4 APIs, and how using them in your 3.x plugins can allow you to access some of the early Eclipse 4 services available through 4.2.

Schedule info

Audience

Track: 
Eclipse Platform/Eclipse 4
Experience level: 
Intermediate
Slides: